This page is updated during active incidents. If your issue is not listed here, please contact our support team. Status updates are posted every 15–30 minutes during ongoing incidents.
Resolved
We've kept an eye on things since the fix went out, and everything's been running smoothly. The issue is now fully resolved — thanks again for your patience!
Monitoring
Between around 09:00 and 09:45 CEST, some of you may have noticed parts of our website loading slowly. This didn't affect all users or all pages.
We've since identified the cause and fixed it. Everything should be back to normal now — thanks for your patience!