This page is updated during active incidents. If your issue is not listed here, please contact our support team. Status updates are posted every 15–30 minutes during ongoing incidents.
This incident has been resolved. Access to our website and account settings has been fully restored, and everything is looking healthy and stable again.
Our game server panel and the game servers themselves were not affected at any point.
Thanks for your patience, and we apologise for any inconvenience.
Resolved
This incident has been resolved. Access to our website and account settings has been fully restored, and everything is looking healthy and stable again.
Our game server panel and the game servers themselves were not affected at any point.
Thanks for your patience, and we apologise for any inconvenience.
Monitoring
We've restored access and are now monitoring closely to make sure everything remains stable.
Investigating
We experienced an issue affecting access to our website and account settings.
We've restored access and are now monitoring closely to make sure everything remains stable.
We apologise for any inconvenience and will post a final update once recovery is confirmed.