Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2025 - 17:55 CEST
Scheduled
The maintenance will take 15 – 30 minutes. During this time, the US website will be unavailable. This maintenance will make the critical backend infrastructure in the USA more stable.
Posted Sep 15, 2025 - 17:54 CEST
This scheduled maintenance affected: Website services (Website (INT), Accounts / Login (INT), Gameserver Webinterface - INT) and Data Center Locations (US - East).